通俗基础教程
电脑操作教程
电脑怎样拨号上网
如何做个人网页
怎样做局域网
Word教程(文字处理)
图形图象处理入门
经典提高教程
怎样使用代理服务器
如何做无盘工作站
Photoshop教程
Dreamweaver3教程
Flash4&5教程
Firework3教程
Frontpage2000教程
Authware教程
Office2000教程
如何制作动画图片
OICQ&ICQ使用方法

高手学习指南

硬件升级技巧
CGI教程
ASP教程

PHP教程

注册表使用技巧
路由器的设置
网站建设指南
SQL
最近更新:
网络知识
相关内容

配置IP路由协议

这一章我们主要介绍
怎样配置各种各样的IP
(Internet IP)路由协议.
IP路由协议分成两大类:
内部网关协议IGPs
(Interior Gateway
Protocols)和外部网
关协议EGPs(Exterior
Gateway Protocols).
  选择路由协议的原则
配置IGRP
Cisco's IGRP 的实现
IGRP的路由交换
IGRP的配置
配置Enhanced IGRP
Cisco's Enhanced IGRP的实现
EIGRP的配置
IGRP到EIGRP的迁移
配置RIP
RIP的配置
RIP与IGRP,EIGRP的迁移
配置静态路由
IP路由协议的配置实例

-----------------------------------------------------------------------

Cisco IOS支持的协议有:

内部网关协议(它是在一个自治系统内部交换路由信息的路由协议)----- IGRP, EIGRP, OSPF, RIP 和 IS-IS等等.

外部网关协议(它是为连接两个或多个自治系统的路由协议)----- BGP 和 EGP等等.


--------------------------------------------------------------------------

选择路由协议的原则

选择一个路由协议是一个非常复杂的工作.当选择路由协议,参考以下几点:

网络的大小和复杂性
支持可变长掩码(VLSM).Enhanced IGRP,IS-IS,OSPF和静态路由支持可变长掩码
网络流量大小
安全需要
网络延迟特性
下面就分别介绍各种路由协议的特点和配置.


--------------------------------------------------------------------------------

配置IGRP

内部网关路由协议(Interior Gateway Routing Protocol---- IGRP)是一个动态的,长跨度的路由协议,它是Cisco公司八十年代中期设计实现的,在一个自治系统内具有高跨度,适合复杂网络的特点.

Cisco's IGRP的实现

IGRP的网络延迟,带宽,可靠性和负载都是可由用户配置决定的.

IGRP广播三种类型的路由:内部的,系统的和外部的.如图所示.内部的路由是在一台路由器的端口上连接子网的路由.如果一台路由器连接的网络是非子网的,IGRP就不广播内部路由.

图 1 :内部,系统和外部路由


系统路由是一个自治系统内的路由.Cisco IOS 软件从直连的网络接口上获得系统路由,并把它提供给其它的支持IGRP协议的路由器或访问服务器.系统路由不包括子网信息.

外部路由是自治系统之间的路由.

IGRP的路由交换

默认的,一个运行IGRP路由协议的路由器每90秒广播一次路由信息.如果在270秒内未收到某路由器的回应,它则认为目前该路由器不可到达;若在630秒后仍未有应答,则把有关它的路由信息从路由表中删掉.

IGRP的配置

指定路由器IGRP协议:

功能 命令
激活IGRP路由,进入路由配置模式 router igrp process number
加入网络直连的网段 nework network-number

请参阅"Configure IGRP Example",更加详细的资料请看 Cisco CD 或 Cisco的主页.


--------------------------------------------------------------------------

配置Enhanced IGRP

Enhanced IGRP是Cisco公司开发的IGRP的增强的版本.它使用与IGRP相同的路由算法,但它在许多方面对IGRP作了较大的改进.

Cisco's Enhanced IGRP的实现

Cisco's Enhanced IGRP提供了以下特性:

自动重新分配-----IP IGRP路由可以自动的重新分配到EIGRP中,IP EIGRP也可以自动的重新分配到IGRP中.如果愿意,也可以关掉重新分配.
可扩展的网络-----对于IP RIP,你的网络最大只有15个hops,而当使用EIGRP时,最大可以有224个hops.
触发的路由表-----EIGRP并不象IGRP那样经过一定的时间间隔后交换路由信息的,而是只有当路由表有变化时才把路由表广播出去的,叫做触发式的(triggered).
支持可变长掩码(VLSM)
配置Enhanced IGRP

指定EIGRP路由协议:

功能 命令
激活EIGRP路由,进入路由配置模式 router eigrp process number
加入网络直连的网段 nework network-number

更加详细的资料请看 Cisco CD 或 Cisco的主页.

IGRP到EIGRP的迁移

在同一个自治系统的IGRP和EIGRP是自动能够重新分配的,而在不同两个自治系统之间,作如下配置:

功能 命令
在路由配置模式下,指定路由重新分配 redistribute protocol [option]
在所有的非IGRP环境下使用相同的metric值 default-metric bandwidth delay reliability loading mtu


请参阅"IGRP and EIGRP Redistribution Example",更加详细的资料请看 Cisco CD 或 Cisco的主页.

--------------------------------------------------------------------------

配置RIP

路由信息协议(Routing Information Protocol ---RIP)是一个相对比较老的,但仍被广泛使用的路由协议.

RIP广播一个UDP数据包更换路由信息,每个路由器间隔30秒更换一次路由信息,在180秒内未收到某路由器的回应,它则认为目前该路由器不可到达;若在270秒后仍未有应答,则把有关它的路由信息从路由表中删掉.

RIP的配置

指定IP RIP路由协议:

功能 命令
激活RIP路由,进入路由配置模式 router rip
加入网络直连的网段 nework network-number

RIP到IGRP,EIGRP的迁移

功能 命令
在路由配置模式下,指定路由重新分配 redistribute protocol [option]
在所有的非IGRP环境下使用相同的metric值 default-metric number

请参阅"RIP and EIGRP Redistribution Example",更加详细的资料请看 Cisco CD 或 Cisco的主页.

-------------------------------------------------------------------

配置静态路由

在某些环境下,我们需要尽量小的路由交换和其它一些特殊环境下会用到静态路由.

功能 命令
在Global配置模式下,指定网关静态路由 ip route network [mask] address [distance]
在Global配置模式下,用串口指定静态路由 ip route network [mask] interface [distance]

请参阅"Static Routing Redistribution Configure Example".
--------------------------------------------------------------------------

IP路由协议实例配置

Configure IGRP Example
IGRP and EIGRP Redistribution Example
RIP and EIGRP Redistribution Example
Static Routing Redistribution Configure Example
Route Filtering Example
Redistribution Filtering
Configure IGRP Example

假设RouterA连接到130.108.0.0和10.0.0.0这两个直连网段上.

RouterA#config terminal (在"#"提示符下)
RouterA(config)#router igrp 15 (进入配置模式)
RouterA(config-router)#network 130.108.0.0 (进入路由配置子模式)
RouterA(config-router)#network 10.0.0.0

IGRP and EIGRP Redistribution Example

在AS 200和AS 100两个自治系统内,分别跑EIGRP和IGRP协议,要想互相通信:

Configuration for RouterA

router eigrp 200
network 201.222.5.0
redistribute igrp 100
default-mertic 56 2000 255 1 1500

router igrp 100
network 131.108.0.0
redistribute eigrp 200
default-metric 56 2000 255 1 1500

RIP and EIGRP Redistribution Example


Configuration for RouterA

router rip
network 201.222.5.0
redistribute eigrp 100
default-mertic 3

router eigrp 100
network 131.108.0.0
redistribute rip
default-metric 56 2000 255 1 1500

Static Routing Redistribution Configure Example

Configuration for RouterA

ip route 131.108.1.0 255.255.255.0 131.108.2.1
!
router eigrp 1
network 192.31.7.0
default-metric 10000 100 255 1 1500
redistribute static
distribute-list 3 out static
!
access-list 3 permit 131.108.0.0 0.0.255.255

Route Filtering Example

在路由器B上,过滤掉由10.0.0.0发送过来的路由信息,那么在201.222.5.0这个网段上是不能与10.0.0.0这个网通信的.换句话说,在201.222.5.0一端隐藏了10.0.0.0这个网.


Configuration for Router

router eigrp 1
network 131.108.0.0
network 201.222.5.0
distribute-list 7 out s0
!
access-list 7 permit 131.108.0.0 0.0.255.255
access-list 7 deny 10.0.0.0 0.255.255.255

Redistribution Filtering

效果同上,但是在两个不同的路由协议下的.


Configuration for Router

router rip
network 201.222.5.0
redistribute eigrp 100
default-mertic 3
!
router eigrp 100
network 131.108.0.0
redistribute rip
default-metric 56 2000 255 1 1500
distribute-list 7 out rip
!
access-list 7 deny 10.0.0.0 0.255.255.255
access-lsit 7 permit 0.0.0.0 255.255.255.255

如何令你的网站“动感十足”
ASP教程:ASP简介
在ASP中使用脚本语言
ASP教程:ASP基础
ASP教程:ASP脚本基础
ASP教程:ASP脚本变量、函数、过程和条件语句
ASP教程:ASP脚本循环语句
ASP教程:ASP内建对象Request
ASP教程:ASP内建对象Response
ASP教程:ASP内建对象Application 和 Session
ASP教程:Global.asa文件的使用及Chat程序
ASP教程:ASP内建对象Server
ASP教程:数据库查询语言(1)
ASP教程:数据库查询语言(2)
ASP教程:ActiveX 组件
ASP教程:其它的ASP常用组件
ASP教程:ADO 存取数据库时如何分页显示
ASP教程:堵住ASP漏洞
ASP教程:最新的ASP、IIS安全漏洞
IP地址与子网掩码
IP路由机制及其在WIN95下的应用
交换网络的路由技术
cisco路由器基本命令配置
cisco路由器配置及维护手册
结合实例讲解广域网路由基本技术
配置IP路由协议
 
 
 
 
 
 
 
 
 
教程站
收集整理